Login page issues
Incident Report for Humi
Resolved
This incident has been resolved.
Posted Aug 17, 2021 - 12:40 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 17, 2021 - 12:33 EDT
Identified
Source of the issue is been identified and the team is working on a resolution.
Posted Aug 17, 2021 - 12:14 EDT
Investigating
Some users are experience load times trying to login to the application
Posted Aug 17, 2021 - 11:58 EDT
This incident affected: Humi (Accounts, Employees, Payroll, Time Off, Performance, Recruiting, Benefits, Documents).