Degraded performance and slower loading times
Incident Report for Humi
Resolved
This incident has been resolved.
Posted Mar 22, 2021 - 17:56 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 22, 2021 - 17:52 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 22, 2021 - 17:52 UTC
Investigating
We are currently investigating this issue.
Posted Mar 22, 2021 - 17:40 UTC
This incident affected: Infrastructure (Core Infrastructure) and Humi (Employees, Payroll, Time Off, Performance, Recruiting, Benefits, Documents).