Increased error rates when processing payroll
Incident Report for Humi
Resolved
This incident has been resolved.
Posted May 17, 2021 - 15:50 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 17, 2021 - 15:04 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 17, 2021 - 14:28 UTC
Investigating
We are currently investigating this issue.
Posted May 17, 2021 - 13:38 UTC
This incident affected: Humi (Payroll).