Payroll outage
Incident Report for Humi
Resolved
This incident has been resolved.
Posted Jul 06, 2021 - 20:47 UTC
Update
We are continuing to monitor for any further issues.
Posted Jul 06, 2021 - 20:26 UTC
Update
We are continuing to monitor for any further issues.
Posted Jul 06, 2021 - 20:06 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 06, 2021 - 19:46 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 06, 2021 - 18:48 UTC
Investigating
We are currently investigating this issue.
Posted Jul 06, 2021 - 18:16 UTC
This incident affected: Humi (Payroll).