Issues loading the site
Resolved

Issues should now be resolved.

Wed, Jan 18, 2023, 10:07 PM
(2 years ago)
·
Affected components

No components marked as affected

Updates

Resolved

Issues should now be resolved.

Wed, Jan 18, 2023, 10:07 PM

Investigating

We're aware of users having issues loading Humi. We're investigating the issuse

Wed, Jan 18, 2023, 09:36 PM(31 minutes earlier)
Powered by