Outage Detected
Incident Report for Humi
Resolved
This incident has been resolved.
Posted Mar 26, 2021 - 14:03 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 26, 2021 - 14:02 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 26, 2021 - 14:00 UTC
Investigating
We are currently investigating this issue.
Posted Mar 26, 2021 - 13:56 UTC
This incident affected: Humi (Employees, Payroll, Time Off, Performance, Recruiting, Benefits, Documents).