Temporary outage on Payroll systems
Incident Report for Humi
Resolved
This incident has been resolved.
Posted Mar 19, 2021 - 17:24 EDT
Update
Payroll systems are fully operational and the team continues to monitor
Posted Mar 19, 2021 - 15:48 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 19, 2021 - 14:17 EDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 19, 2021 - 14:02 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 19, 2021 - 14:02 EDT
Investigating
We are currently investigating this issue.
Posted Mar 19, 2021 - 12:23 EDT
This incident affected: Humi (Payroll).