Users unable to login
Incident Report for Humi
Resolved
This incident has been resolved.
Posted Apr 01, 2021 - 16:39 UTC
Investigating
We are currently investigating this issue.
Posted Apr 01, 2021 - 16:39 UTC
This incident affected: Humi Client Portal (Employees).