System Performance Degraded
Incident Report for Humi
Resolved
This incident has been resolved.
Posted Jul 23, 2021 - 17:58 UTC
Monitoring
System is back to normal
Posted Jul 23, 2021 - 17:36 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 23, 2021 - 17:28 UTC
Investigating
We are currently investigating this issue.
Posted Jul 23, 2021 - 17:24 UTC
This incident affected: Humi (Accounts, Employees, Payroll, Time Off, Performance, Recruiting, Benefits, Documents).