Performance degradation
Incident Report for Humi
Resolved
This incident has been resolved.
Posted Jun 01, 2021 - 16:56 EDT
Update
We are continuing to monitor for any further issues.
Posted Jun 01, 2021 - 16:34 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 01, 2021 - 16:33 EDT
Investigating
We are currently investigating reports of Humi login and certain parts of the application being slower than normal
Posted Jun 01, 2021 - 16:10 EDT
This incident affected: Humi (Accounts, Employees, Payroll, Time Off, Performance, Recruiting, Benefits, Documents).