System performance degraded
Incident Report for Humi
Resolved
This incident has been resolved.
Posted Jul 27, 2021 - 19:53 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 27, 2021 - 19:09 UTC
Investigating
We are currently investigating this issue.
Posted Jul 27, 2021 - 19:06 UTC
This incident affected: Humi (Accounts, Employees, Payroll, Time Off, Performance, Recruiting, Benefits, Documents).