System Performance Degradation
Resolved·Degraded performance

Our team has identified the issue and fixed the affected servers.

Mon, Mar 15, 2021, 03:29 PM
(4 years ago)
·
Affected components
Updates

Resolved

Our team has identified the issue and fixed the affected servers.

Mon, Mar 15, 2021, 03:29 PM

Investigating

We are currently investigating this issue.

Mon, Mar 15, 2021, 03:00 PM(28 minutes earlier)
Powered by