Issues loading the application
Incident Report for Humi
Resolved
This incident has been resolved.
Posted Jan 18, 2023 - 17:27 EST
Monitoring
The application should now be accessible, we are monitoring for any ongoing issues.
Posted Jan 18, 2023 - 16:46 EST