Loading error on login
Incident Report for Humi
Resolved
This incident has been resolved.
Posted May 18, 2022 - 17:39 EDT
Update
We have concluded our investigation into the issue, we have isolated the issue to legacy versions of the Safari browser.

If you are still encountering issues, please update your browser to the latest version.
Posted May 18, 2022 - 17:38 EDT
Investigating
Some customers are unable to log in using the Safari browser. We're currently investigating the issue, and will provide an update soon.
Posted May 18, 2022 - 16:13 EDT
This incident affected: Humi (Accounts, Employees, Payroll, Time Off, Performance, Recruiting, Benefits, Documents, Billing (Stripe API)).