Increased loading times
Incident Report for Humi
Resolved
This incident has been resolved.
Posted Jun 14, 2021 - 19:28 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 14, 2021 - 19:25 UTC
Investigating
Time is experienced an increase on API response timesw
Posted Jun 14, 2021 - 19:12 UTC
This incident affected: Humi (Accounts, Employees, Payroll, Time Off, Performance, Recruiting, Benefits, Documents).