Slower application response times
Incident Report for Humi
Resolved
This incident has been resolved.
Posted Mar 25, 2021 - 18:25 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 25, 2021 - 18:23 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 25, 2021 - 18:19 UTC
Investigating
We are currently investigating this issue.
Posted Mar 25, 2021 - 18:16 UTC
This incident affected: Humi (Employees, Time Off, Performance, Recruiting, Benefits).