Reports of issues with Payroll processing
Resolved·Degraded performance

This incident has been resolved.

Fri, Mar 19, 2021, 03:05 PM
(4 years ago)
·
Affected components
Updates

Resolved

This incident has been resolved.

Fri, Mar 19, 2021, 03:05 PM

Monitoring

A fix has been implemented and we are monitoring the results.

Fri, Mar 19, 2021, 03:01 PM

Identified

The team has narrowed down the issue to paystub emails not being sent, at this time seems actual payments where not affected.

Fri, Mar 19, 2021, 02:04 PM(57 minutes earlier)

Identified

The team has identified the cause of the issues and working to have the issue resolved as soon as possible.

Fri, Mar 19, 2021, 01:44 PM(20 minutes earlier)

Investigating

Currently investigating issues with payroll processing for some users

Fri, Mar 19, 2021, 01:37 PM
Powered by